Million e-Leave Manual v1.0

1. Registeration
Please provide your flavor subdomain(company id), name, login email, login password and phone
number.

1.1. URL structure
User later will get this link https://{subdomain}.hrmillion.com OR {subdomain}.hrmillion.com
ex: https://yourcompanyid.hrmillion.com OR yourcompanyid.hrmillion.com

2. Login

e-Leave

testcompany @test.com

Figure 2.a Login Screen

i Please key in your login email address (or user id if known) and login password.
Note:
- The default user id for

Administrator : Million123gaz
- The default password for
Staff : Million123456

ii.  Once login, you will see the dashboard ‘s screen as shown in Figure 2.b.
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Figure 2.b e-Leave ‘s Dashboard


https://yourcompanyid.hrmillion.com

3. General Setup

Dashboard / Sefting - General Setup

General Setup

Annual Leave Entitlement Based On

® This year work done Last year work done

Allow applicant apply Annual Leave in advance

Figure 3.a General Setup ‘s screen

i From side menu, select Setting->General Setup, you will see General Setup’s screen as shown in
Figure 3.a.
ii.  Press Save button to save your settings.

4. Maintenance

Next, we will proceed to create new record for Branch, Department, Leave Code, Leave Table and
lastly Employee.

There are 3 methods to insert your data :

A. Import from Excel File(.xIsx)

B.  Synchronize from Million Payroll

C. Create Manually on e-Leave

4.1. Import from Excel File(.xIsx)

Dashboard / Import Excel

Import Excel (XLSX)

| cnoose File | No fie cnosen

Read XLSX

Figure 4.a Import Excel ‘s screen

i From side menu, select Import Excel, you will see Import Excel’s screen as shown in Figure 4.a.
|

Generate Template
[suideline
Employee Branch Department LeaveTable

LeaveCode

Figure 4.b Template and Guideline in Import Excel ‘s screen

i. Press Generate Template Button and ml_importexcel.xlsx will be generated.
ii.  You can refer to Guideline’s tabs as shown in Figure 4.b as reference.
ili. Press Read XLSX.



Excel Import - Preview

employee branch department lea
No. Name Email Branch Dept Leave Table  Date Join Status
EMPO1  Andrew andrew@test.com PNG sLs Lo 2012-1201  C

No record in excel file. [Below employee 's status will be set as 'Non-Active’]

Figure 4.c Preview data before import

Type

PM New

iv.  System will validate data and result will be shown under Excel Import - Preview.

Note:
-System will import New data only.

-System will update the particular employee’s status to Non-Active in e-Leave if such employee is

missing inside the excel file.

v.  Press Import button and system will redirect back to dashboard after import finish.

4.2. Synchronize from Million Payroll

e Edit User Account # admin I
; Useri admin v
Name Admin
Password LXTITIT]

[ pisplayCharacters
Group Admin

Email

Email Password Oniyaccept0to9,atoz, AtoZ @

SMTP Server Hotmail Gmail  Yahoo

Server Por 0

¥l Use ssL

Confidential Level 0

Additional Information

Il save X Cancel

Figure 4.d User Account Maintenance in Million Payroll

° Additional Information _‘
E-Leave Setting.
userip
Password
Company ID
~ oK X cancel

Figure 4.e Million Payroll’s User Account

i In Million Payroll, go to System->Administrative Tools->User Account->Admin->Edit. Press
Additional Information at the bottom left corner as shown in Figure 4.d.

li. Keyin your e-Leave ‘s authentication
-login email/user id

-login password

-subdomain/company id



@ Synchroize with E-Leave S
Export the following data

Employee, Branch, Department and Leave Tables

[ Holiday 4

Impaort the following data

|:| Import Employee Leave Records

From Date 01/02/2020

To Date 29/02/2020

~ oK X cancel

Figure 4.f Million Payroll’s Synchronize with E-Leave

lii. Go to System->Administrative Tools->Synchronize with E-Leave, tick Employee, Branch,
Department and Leave Tables and press OK as shown in Figure 4.f.

4.3. Create Manually on e-Leave
4.3.1. Create Branch

Dashboard / Sefting - Branch

Branch Change Table Seting ‘W import Excel
Search Q
| esv H Excel H POF |

# Code Description Action

1 PNG Penang @ Edit
X Delefe

Figure 4.g Branch Maintenance

Branch

Code

Description

Figure 4.h Branch’s modal box
. Go to Setting->Branch->Add as shown in figure 4.g, a modal will prompt out.
Il.  Key in your branch’s code and branch’s description, press Save button to close the modal.

4.3.2. Create Department

Department
Code MNG

Description

Management

Figure 4.i Department’s modal box

. Go to Setting->Department->Add, a modal will prompt out.

li. Keyinyour department’s code and department’s description, press Save button to close the
modal.



4.3.3. Create Leave Code

Leave Code

Code ALZ

Description

Annual Leave 2|

Figure 4.j Leave Code’s modal box
.  Go to Leave->Leave Code->Add, a modal will prompt out.
Il.  Key in your leave code and leave code’s description, press Save button to close the modal.

4.3.4. Create Leave Table

0ard / Leave - Leave Table Listing

Leave Table Change Table Setting W import Excel.
Search Q
‘ osv || Excel |\ POF ‘
N Description Action
1L Leave Table #Sample @ Edt
% Delote

Figure 4.k Leave Table Maintenance

Dashboard | Leave - Leave Table Listing / Add

Header - Leave Table

Table No. L1

R s Leave Table #1 MNG

Figure 4.1 Leave Table’s Header

Dashboard / Leave - Leave Table Listing ' Add

Header - Leave Table

Table No. L1

Tate Bescnphon Leave Table #1 MNG
Body - Leave Table Preview - Leave Table
Leave
Tyee Annual Leave = From Year To Year Entitle CF Action

No data available in table
From 1
Year
Back
To Year 3
2

Entitle 12
CF 3

Figure 4.m Leave Table’s Body

I.  Go to Leave->Leave Table->Add, system will direct to new page as shown in figure 4.

II.  Only header part of leave table will be shown at first, key in your table no and description, body
part of leave table will be shown after header part is created.



Dashboard / Leave - Leave Tabl

Header - Leave Table

Body - Leave Table

Leave

Listing / Add

Table No.

Table Description

L1

Leave Table #1 MNG

Preview - Leave Table

Medical Leave = To Year Entitle CF Action
Type
Annual Leave
From
Yaar 1 3 12 3 00
To Year 3 5 16 5 @ o
Entitle 6 2 24 7 00
Medical Leave
CcF
1 99 20 0 00

Figure 4.n Leave Table Maintenance

lll.  Maintain your leave entitlement line by line, press Submit button to create new record
IV. Created records will be shown at right side Preview - Leave Table as shown in figure 4.n.

4.3.5. Create Employee

Dashboard / Emg

Login Information

User ID Super
Password

Note for [Password]

Employment

Date Join

Employee Status

Employment Type

@ | 26/02/2010

Confirmed 84

Permenant o

To reset password, Kindly enter new password.
Otherwise, leave BLANK to stay default

Setting
General Information
Leave Table Leave Table #Sample -
Employee No. SUPO1
Role Admin ¥ Superior ¥ Employee
Name James(Super)
Email -

X super@test.com

Branch Penang -

Department Sales -

Figure 4.0 Employee Maintenance

. Go to Employee->Add, system will direct to new page as shown in figure 4.0.

II.  Keyin new employee’s information, press Submit to create new record.

Note When Creating New Employee:

-System will use default password Million123456 if password’s field is blank.

-Please key in Valid Email, such as system will send notification email to respective employees.
-Please key in Valid Date Join, such as system will use this information to calculate leave entitlement.
-Whoever Employee Status is set to Non-Active, the particular employee will not be able to login into
e-Leave, unable to receive email and will be excluded from subscription’s employee limit.

-For management team who wish to receive notification from applier, please tick Superior(Section
4.4 will further explain about superior maintenance).



4.4. Superior Maintenance

Superior

Code SUPPNG1

Description Supervisor Penang #1

LinicTo Supervisor

Select All | UnSelect All

Super Admin Supervisor
“ Ben

Figure 4.p Superior Maintenance

i.  Goto Employee->Edit particular employee (example: Supervisor)->Tick ‘Superior’ at
Roles->Submit

ii.  Go to Setting->Manage Superior->Add, a modal will prompt out as shown in Figure 4.p.

iii. Key in superior code, descption and link this superior setting to that particular employee
(example: Supervisor).

iv. Select your flavor staff(s). These staff(s) ‘s leave request will later appear in Superior’s Dashboard
for further action such as approve leave and now this particular employee (example: Supervisor) will
also able to receive notification when Ben apply leave too.

5. Employee’s Panel
Please complete section 4 before proceed to 5.

5.1. Login
Please get login information from your administrator.
Note:
Default password is Million123456 if administrator previously does not update employee’s password.
= £ Ben
Welcome, Ben i Thursday 20 February 2020

ﬂ Announcement
42% Employee

test

2 |eave

test2

My Panel Information

x PENDING - APPROVAL - REJECTED Upcoming Leave

Figure 5.a Employee Dashboard

I.  After login, employee will see dashboard as shown in Figure 5.a.



5.2. Change Login’s Password

Dashboard | Employee Listing / View
Login Information
UserID Ben
Password

Note for [Password]
To reset password, Kindly enter new password.
Otherwise, leave BLANK 10 stay default

General Information

Employee No.

Ben
Name Ben
Email =

X | elainetanhomeyitt@gmail.com

Figure 5.b View Employee

Employment

Date Join 01/06/2013

Employee Status

Employment Type

Setting
Leave Table 5
Role Admin Superior ¥ Employee
E

i.  Goto Employee->View->Key in your new password->Submit.

Note:

Only password’s field is editable.

5.3. Leave Request

Dashboard / Leave - Leave Apply Listing

Leave Apply Changs Table Setting

All Pending Upcoming History
Search Q
| csv ‘ i Excel ‘ ‘ PDF i
# Emp No. Name Type From To Day Remark Created At Action Status
No data available in table
Figure 5.c Leave Apply Listing
5.3.1. Employee Apply Leave (Pending Approval)
Dashboard / Leave - Leave Apply Listing / Apply
Leave Information
Code Max Entitle Entitle BIF Adjust Replace Taken Balance Claimable
AL 16.00 2,67 0.00 0.00 0.00 0.00 267 0.00
Please select leave date(s) DEPRETMENT
SALES
DATE JOIN
- 2013-06-01
April 2020 today | < >
SELECTED DAY : 1 DAY(S)
Sun Mon Tue Wed Thu Fri Sat FROM AM v 2020-08-15
1 2 3 4
TO PM v 2020-04-15
5 6 7 8 9 10 1
Employee
Ben =
12 13 14 15 16 17 18 Leave Type
Annual Leave ¥
19 20 21 22 23 24 25 Remmark
AL 1 day
26 27 28 29 30

Figure 5.d Apply Leave’s screen

Attach(Optional) JPG/JPEG/GIF/PNG/PDF

 Browse

Back



. Go to Leave->Leave Apply->Add as shown in figure 5.c, system will direct to new page as shown
in figure 5.d.

Il.  Choose your leave date by clicking on Calendar.

Ill.  Select AM to PM for FULL day (AM to AM or PM to PM will consider as HALF day)

IV. Key in your remarks as this is required field, press submit to create your leave request

V. System will send a notification to Supervisor.

Dashboard / Leave - Leave Apply Listing

Leave Apply Change Table Sefting

All History
Search Q
csv || Excel || PDF

#  EmpNo. Name Type From To Day Remark Created At Action Status
1 Ben Ben Annual Leave ~ 2020-0415  2020-04-15  1.00 AL 1 day 2020-02-2109.46:17 Status - Pending Approval

Updated by : Ben

L EECS  Updated at : 2020-02-21 09:46:17

Figure 5.e Leave Request in Pending Approval Status

VI.  You new leave request will be shown in listing which is in Pending Approval status.
Note:
You may still can edit or delete the transaction at this stage.

6. Supervisor’s Panel

Please complete section 4 before proceed to 6.

6.1. Login

Please get login information from your administrator.

Note:

Default password is Million123456 if administrator previously does not update employee’s password.

3 Announcement

test

test2

Leave Pending Change Table Setting

# Emp No. Name Type From To Day Remark Created At Action Status

1 Ben Ben AnnualLeave  2020-04-15 20200415 100 AL 1 day 2020-02-21 09:46:17 @ Status - Pending Approval
Updated by : Ben
Updated at : 2020-02-21 09:46:17

My Panel Information

PENDING APPROVAL REJECTED

b 4 V4 Q Upcoming Leave
Figure 6.a Supervisor Dashboard

I.  After login, supervisor will see dashboard as shown in Figure 6.a.
Il.  Ben’s leave request wll be shown at Leave Pending’s Panel.

6.2. Change Login’s Password

csv Excel PDF

Emp Date
# No. Name Join Email Branch Dept Type Status Role Action

1 Ben Ben 2013-06-01 Penang Sales Permenant  Extended & View

2 Supervisor  Supervisor 2012-02-05 Penang IManagement  Permenant  Confirmed & view

Figure 6.b Employee Listing



. You may refer to Section 5.2.
Note:
-Supervisor able to edit Employee’s password who is being assigned under this supervisor.

6.3. Leave Request
6.3.1. Apply Leave

i.  You may refer to Section 5.3.1.

6.3.2. Approve Leave

Dashboard / Leave - Leave Approve Listing / Approve
Summary #2002219473
April 2020 oy < | >
No. Ben
Sun Mon Tue Wed Thu Fri Sat Name Ben
2 30 31 1 2 3 4 Department Sales
Apply For AL
5 8 7 8 9 10 1 - i
AM/IPM AM to PM
Date 2020-04-15
12 13 14 15 16 17 18 Remark AL 1 day
[ALIBen Attachment No
19 20 21 22 23 24 25 status Pending Approval
Approve Reject
26 27 28 29 30 1 - -

Back

Figure 6.c Detail of Leave Approve

i.  Go to Dashboard->Under Leave Pending’s panel->Detail OR go to Leave->Leave Approve->Detail.
System will direct to new page as shown in figure 6.c.

ii.  Supervisor has 2 options (a.) or (b.)

(a. ) Approve - Leave Status will change from Pending Approval to Leave Approved(green), leave
balance will be deducted.

(b. ) Reject - Leave Status will change from Pending Approval to Leave Rejected(red), leave balance
will remain unchange.

Note:

Modal box will prompt out if supervisor plans to reject the request as shown in figure 6.d. Reason is
optional

Rejecting Leave Request

Reason (Optional)

Figure 6.d Reject Leave Request



7. Report

Dashboard / Reports - Leave Entitlement Report

Filter - Leave Entitliement Report

Employee 2 Branch - Al =

Leave _ Salee A - Department et A

Year 2020 =

Preview Export XLSX Export PDF

# Emp No. Name Leave Max Entitle Entitle BIF Adj Replacement
1 4 Super Admin Annual Leave 16.00 267 0.00 0.00 0.00
2 -1 Super Admin Examination Leave 200 2.00 0.00 0.00 0.00
3 Ben Ben Annual Leave 16.00 2.67 0.00 0.00 0.00
4 Ben Ben Examination Leave 200 2.00 0.00 0.00 0.00
5 Supervisor Supervisor Annual Leave 16.00 267 0.00 0.00 0.00
6 Supervisor Supervisor Examination Leave 2.00 2.00 0.00 0.00 0.00

Figure 7.a Leave Entitlement Report

. Login in as Administrator.
Il.  Go to Report->Leave Entitlement Report->Preview

8. Export Leave to Million Payroll

- Synchroize with E-Leave = O
mploy sports
Export the following data

[Jempioyee, Branch, Department and Leave Tables

All{| [DHotiday ition

Import the following data

Import Employee Leave Records

From Date 01/04/2020

To Date 30/04/2020

v oK X tancel

Figure 8.a Million Payroll’s Synchronize with E-Leave.
. Please complete Section 4.2 (i)&(ii) first.

Il.  Go to System->Administrative Tools->Synchronize with E-Leave.

lll.  Tick Import Employee Leave Records and key in the dates->OK.

Employee Leave Record # BEN - Ben ﬁ]
Date Leave Description Day  Remark Fl. [®
AL ANNUAL LEAVE 1.00 AL1 day [} |

Figure 8.b Million Payroll’'s Employee Leave Record

Taken

IV. Go to Employee->Leave->Employee Leave Record->Edit Employee.
V. You will see the e-Leave transaction is being updated to Million Payroll.

Balance

Claim



9. Additional Information
Now let’s take further step to cancel this leave (15/04/2020)
9.1. Employee - Cancel Leave

Leave Information

Code Max Entitle Entitle BIF Adjust Replace Taken Balance Claimable

AL 16.00 267 0.00 0.00 0.00 1.00 167 0.00

DEPARTMENT
SALES

DATE JOIN
2013-06-01

Please select leave date(s).

February 2020 tosay | | < | >

SELECTED DAY : 1.00 DAY(S)

Sun Mon Tue Wed Thu Fri Sat FROM M 2 2020.04-15
r
TO PM v 2020-04-15
2 3 4 5 6 7 8
® f;ﬁ;giPPROVED
REASON
9 10 11 12 13 14 15
Employee
16 17 18 19 20 21 2 il :
Leave Type
Annual Leave ¥
23 24 25 26 27 28 29
Remark
AL 1 day
JPGI.
Back

Figure 9.a Employee’s Approved Leave

i Go to e-Leave and login in as employee
ii. Goto Leave->Leave Apply->View->| wish to cancel this leave.

| csv |\ Excel || PDF |
It Y W Al |
# Emp No. Name Type From To Day Remark Created At Action Status
1 Ben Ben Annual 20200415 2020-04-15  1.00 AL 1 day 2020-02-21 09:46:17  view | Status:Pending Cancellation

Leave Updated by : Ben
Updated at: 2020-02-21 10:51:10

Figure 9.b Employee Listing
iii. Now your request’s status will become Pending Cancellation.

9.2. Supervisor-Approve Cancellation

Summary #2002219473

April 2020 ooy (Bl
No. 3en
sun Mon Tue Wed Thu Fri sat Name 3en
29 30 31 1 2 & 4 Department  Sales
Apply For aL
5 6 7 8 9 10 1 o o
AWPM AMtoPM
Date 20200415
12 13 14 15 16 17 18 Remark AL 1 day
{ALBen Attachment  No
19 20 21 2 23 24 25 status Pending Cencellation
Aumuwlm;e Re}ecl
26 27 28 29 30 1 2
Back

Figure 9.c Supervisor’s Leave Approve Detail



. Login e-Leave as supervisor.

Il.  Go to Leave->Leave Approve->Click Pending Cancellation’s Tab->Detail

Ill.  Thereis 2 options (a.) or (b.)

(a. ) Acknowledge - Leave will be cancelled successfully, Ben will back to work and leave balance will
be added back. Leave Status will become Cancellation Acknowledged(red).

(b. ) Reject - Leave will not be cancalled, Ben will be on leave on 15/04/2020 and leave balance will
remain taken 1. Leave Status will become Cancellation Rejected(green).

# Emp No. Name Type From To Day Remark Created At Action status

1 Ben Ben Annual 2020-04-15  2020-04-15  1.00 AL 1 day 2020-02-21 09:46:17 @ Defail ‘Status : Cancellation Acknowledged
Leave Updated by :
Upgaled at- 2020-02-21 11:06:38

Figure 9.d Superior’s Leave Approve Listing

10. Reference
10.1. E-Leave’s status

Pending Approval (Emp)

Leave Rejected [Super) Leave Approved (Super)

Pending Cancellation (Emp) Leave Cancelled [Super)

Cancellation Rejected {Super) Cancellation Acknowledzed [Super)




